tigtools

เครื่องคำนวณ CIDR / Subnet

ป้อนที่อยู่พร้อม prefix เช่น 10.0.0.0/16 หรือ 2001:db8::/48 เพื่อดูช่วงทั้งหมด mask และโครงสร้างไบนารี

ทำงานในเบราว์เซอร์ของคุณ ไม่ต้องสมัคร

ตัวอย่าง: 192.168.1.10/24, 10.0.0.0 255.255.0.0, 2001:db8::/48

รายละเอียดซับเน็ต
เครือข่าย (CIDR)192.168.1.0/24
ที่อยู่เครือข่าย192.168.1.0
ที่อยู่ broadcast192.168.1.255
โฮสต์ที่ใช้ได้ตัวแรก192.168.1.1
โฮสต์ที่ใช้งานได้สุดท้าย192.168.1.254
โฮสต์ที่ใช้ได้254
จำนวนที่อยู่ทั้งหมด256
เน็ตมาสก์255.255.255.0
ไวลด์การ์ดมาสก์0.0.0.255
ประเภทที่อยู่ส่วนตัว (RFC 1918)
คลาสดั้งเดิมC

มุมมองไบนารี

11000000.10101000.00000001.00001010  ที่อยู่
11111111.11111111.11111111.00000000  เน็ตมาสก์
11000000.10101000.00000001.00000000  ที่อยู่เครือข่าย
11000000.10101000.00000001.11111111  ที่อยู่ broadcast

บิตจำนวน 24 บิตแรกเป็นส่วนของ network ส่วนที่เหลือใช้ระบุ host

ปัดขึ้นเป็นเลขยกกำลังสอง ได้ไม่เกิน 1,024 ซับเน็ต

4 ซับเน็ตขนาด /26 มีโฮสต์ที่ใช้ได้ซับเน็ตละ 62

#เครือข่าย (CIDR)ช่วงโฮสต์ที่ใช้ได้ที่อยู่ broadcast
1192.168.1.0/26192.168.1.1 – 192.168.1.62192.168.1.63
2192.168.1.64/26192.168.1.65 – 192.168.1.126192.168.1.127
3192.168.1.128/26192.168.1.129 – 192.168.1.190192.168.1.191
4192.168.1.192/26192.168.1.193 – 192.168.1.254192.168.1.255

วิธีใช้งาน

  1. พิมพ์ที่อยู่ IPv4 พร้อม prefix (192.168.1.10/24) หรือ netmask แบบจุด (192.168.1.10 255.255.255.0) หรือที่อยู่ IPv6 พร้อม prefix
  2. ดูค่า network, broadcast, ช่วง host, จำนวน และ mask ในตาราง
  3. สำหรับ IPv4 ให้ดูมุมมองไบนารีเพื่อดูว่าส่วน network สิ้นสุดที่ใด
  4. หากต้องการวางแผนซับเน็ต ให้ป้อนจำนวนที่ต้องการ เครื่องมือจะแสดงรายการซับเน็ตแต่ละรายการพร้อมช่วง host

วิธีการทำงาน

สำหรับ IPv4 แอดเดรสและเน็ตมาสก์จะถูกประมวลผลเป็นตัวเลข 32 บิต แอดเดรสเครือข่ายคือแอดเดรสที่บิตโฮสต์ทั้งหมดเป็น 0 และแอดเดรสบรอดแคสต์มีบิตโฮสต์ทั้งหมดเป็น 1 โฮสต์ที่ใช้งานได้คือแอดเดรสที่อยู่ระหว่างสองค่านี้ ดังนั้น /24 จึงมี 256 แอดเดรสและโฮสต์ที่ใช้งานได้ 254 แอดเดรส มีสองพรีฟิกซ์ที่พิเศษ: /31 มีแอดเดรสที่ใช้งานได้สองแอดเดรสสำหรับลิงก์แบบจุดต่อจุด (RFC 3021) และ /32 คือโฮสต์เดียว ไวลด์การ์ดมาสก์คือค่าเน็ตมาสก์กลับด้าน ตามที่ใช้ใน Cisco ACLs และคำสั่ง OSPF เน็ตมาสก์แบบจุดจะยอมรับเฉพาะเมื่อบิต 1 ต่อเนื่องกัน

ชนิดแอดเดรสจะระบุว่าแอดเดรสเป็นแบบส่วนตัว (10/8, 172.16/12, 192.168/16), พื้นที่ NAT ระดับผู้ให้บริการที่ใช้ร่วมกัน (100.64/10), ลูปแบ็ก, ลิงก์โลคอล, มัลติคาสต์, สงวนไว้สำหรับเอกสาร หรือสาธารณะ คลาส (A–E) แสดงไว้เพื่อการอ้างอิงเท่านั้น การกำหนดแอดเดรสแบบแบ่งคลาสไม่ได้ถูกใช้สำหรับการเราต์ติ้งแล้วตั้งแต่ CIDR ถูกนำมาใช้ในปี 1993

การแบ่งจะแบ่งเครือข่ายออกเป็นซับเน็ตย่อยเท่า ๆ กัน จำนวนที่คุณป้อนจะถูกปัดขึ้นเป็นเลขยกกำลังสองถัดไป เนื่องจากบิตพรีฟิกซ์ที่เพิ่มขึ้นหนึ่งบิตจะเพิ่มจำนวนเป็นสองเท่า รายการซับเน็ตจะแสดงสูงสุด 1,024 รายการ

สำหรับ IPv6 การคำนวณเลข 128 บิตใช้ BigInt จึงแม่นยำแม้แต่ /0 คุณจะได้รูปแบบย่อ (RFC 5952: ตัวพิมพ์เล็ก, ตัดเลขศูนย์นำหน้าออก, กลุ่มศูนย์ที่ต่อเนื่องยาวที่สุดแทนด้วย ::), รูปแบบขยายเต็ม, แอดเดรสแรกและสุดท้ายของพรีฟิกซ์, จำนวนแอดเดรส และสำหรับพรีฟิกซ์สูงสุด /64 ว่ามี /64 ซับเน็ตย่อยได้กี่เครือข่าย โซนอินเด็กซ์เช่น %eth0 จะถูกละเว้น

ตัวอย่าง

เครือข่ายสำนักงาน

192.168.10.0/23 ให้เครือข่าย 192.168.10.0, บรอดแคสต์ 192.168.11.255, โฮสต์ 192.168.10.1 ถึง 192.168.11.254 (ใช้งานได้ 510), เน็ตมาสก์ 255.255.254.0 และไวลด์การ์ด 0.0.1.255

การแบ่งสำหรับ VLAN

ป้อน 10.20.0.0/22 แล้วแบ่งเป็น 3 จำนวนจะถูกปัดขึ้นเป็น 4 ทำให้ได้เครือข่าย /24 สี่เครือข่าย ตั้งแต่ 10.20.0.0/24 ถึง 10.20.3.0/24 แต่ละเครือข่ายมีโฮสต์ 254 แอดเดรส

การจัดสรร IPv6

ผู้ให้บริการกำหนด 2001:db8:abcd::/48 เครื่องมือจะแสดงแอดเดรสสุดท้าย 2001:db8:abcd:ffff:ffff:ffff:ffff:ffff และแสดงว่ามี /64 ซับเน็ตย่อย 65,536 เครือข่ายที่บรรจุได้

คำถามที่พบบ่อย

ทำไม /24 จึงมีโฮสต์ที่ใช้งานได้ 254 แอดเดรส ไม่ใช่ 256?

แอดเดรสแรกใช้ระบุเครือข่าย และแอดเดรสสุดท้ายคือแอดเดรสบรอดแคสต์ จึงไม่สามารถกำหนดให้กับอุปกรณ์ได้ ทำให้เหลือ 256 − 2 = 254

Wildcard mask คืออะไร

มันคือ netmask ที่กลับค่าทุกบิต เช่น 0.0.0.255 สำหรับ 255.255.255.0 เราเตอร์อย่าง Cisco ใช้ใน access list และ OSPF network statement

ทำไมจึงแบ่งได้เฉพาะซับเน็ต 2, 4, 8… เท่านั้น

ซับเน็ตที่สร้างโดยการขยาย prefix จะมีขนาดเท่ากันเสมอ และทุกบิตที่เพิ่มจะทำให้จำนวนเพิ่มเป็นสองเท่า หากคุณต้องการ 5 เครือข่าย คุณจะได้ 8 และสามารถเว้นว่าง 3 เครือข่าย หรือวางแผนซับเน็ตขนาดต่างกันเอง (VLSM)

เครื่องมือนี้ค้นหาเจ้าของที่อยู่ IP หรือไม่

ไม่ ทุกอย่างคำนวณจากตัวเลขที่คุณป้อน โดยไม่มีการสอบถามบริการ WHOIS, DNS หรือระบุตำแหน่งทางภูมิศาสตร์

ความเป็นส่วนตัว

การคำนวณทั้งหมดทำงานในเบราว์เซอร์ของคุณ ที่อยู่ที่คุณป้อนจะไม่ถูกส่งไปที่ใด ไม่ถูกจัดเก็บ หรือรวมอยู่ในข้อมูลวิเคราะห์